support reviews loopmasters.com
macpc
32-bit / 64-bit

Analog Channel HD

Channel Strip by McDSP

Protoolerblog 160 pluginboutique
“Crank the input and the drive for some saturated goodies. I find it very useful on aggressive vocals but it can, of course, be used on just about anything from drums to synths to guitars to balalaikas.”
ProToolerBlog. With millions of hits monthly and several thousand unique visitors a day, ProToolerBlog is the largest website in the world dedicated to Pro Tools.

Note: This product is the HD version. You can purchase the Native version HERE.

Analog Channel emulates the sounds of high-end analog tape machines, tape, and channel amplifiers.

Analog Channel is 2 plug-ins:

  • AC101 – Emulates analog channel amplifier circuits
  • AC202 – Emulates analog tape machines

The AC101 configuration acts as a digital pre-amp allowing even excessive amounts of gain without digital distortion. A drive control determines where the audio “sits” in the saturation/compression region, and even the attack and release times of the distortion character are adjustable.

The AC202 configuration emulates analog tape machines. In addition to standard tape machine parameters such as bias, playback speed, and IEC1/2 equalization, AC202 offers controls well beyond the limits of the reel-world devices including adjustable low frequency roll off and head bump – independent of playback speed. The user can select from several playback head types, tape formulations, and even control the tape saturation recovery time.

Features

  • Library of presets emulating analog mixing systems
  • Real-time display of saturation curves and calibrations
  • Analog Saturation modeling
  • Double precision processing
  • Ultra low latency
  • Mono and stereo versions

System Requirements

Mac:

  • OSX 10.8 (or higher)

Windows:

  • Windows 7 (or higher)

Formats:

  • AAX DSP/Native
  • AU
  • VST

Platform Requirements:

  • AAX versions require Pro Tools 10.3.8 or higher, or Pro Tools 11.1.3 or higher
  • S3L/S6L versions require VENUE OS 5.2 or higher
  • AU versions recommended for Logic 9, X, or higher
  • VST versions recommended for Cubase 7.x, 8.X, or higher, and Nuendo 6.5 or higher

Important Note: This plugin requires a iLok2 or iLok3 USB smart key for authorization. This can be purchased HERE.

More by McDSP

  • top rated
osxpc
Futzbox pluginboutique
5(1)
your price$179.00
    osxpc
    950x426 mcdsp futzbox meta pluginboutique
    starts from$129.00
    learn more
    • award
    osxpc
    950x426 mcdsp ml8000 meta pluginboutique
    starts from$129.00
    learn more
    • top rated
    osxpc
    Ml4000 limiter ml4 pluginboutique
    5(9)
    your price$179.00
      osxpc
      950x426 mcdsp spc2000 meta pluginboutique
      starts from$99.00
      learn more