support reviews loopmasters.com
macpc
32-bit / 64-bit

Revolver Native

Reverb by McDSP

Macprovideo pluginboutique
“I always love how McDSP plugins can be both transparent and musical at the same time.”
macProVideo.com. macProVideo.com is an online education community featuring Tutorial-Videos & Training for popular Audio & Video Applications.

Revolver is a high-powered convolution reverb that operates like no other, providing total impulse response control, dedicated and routable EQ, two sync-able delay lines, a reverb decay crossover network, and specialized stereo imaging for unprecedented flexibility.

Revolver provides the most compelling impulse library to date, with hundreds of sounds from rare holy grail out of production reverbs and acoustic spaces. Additional acoustic spaces and outboard gear can be modeled in a few minutes with Revolver and the Revolver impulse response tools.

Controls for the total reverb time (in percent and RT60 values), wet and dry levels are always displayed. The remainder of the Revolver plug-in interface is separated into several control pages and views. Graphical representations of signal flow, impulse response data, EQ responses, and even images of the impulse response source are available

All parameter adjustments are heard immediately, and the outputs are not muted during any control updates. The user does not need to wait while the reverb is re-rendered.

Revolver is what convolution reverb was always meant to be.

Features

  • Huge library of presets of out of production reverbs, rare vintage reverbs, and acoustic spaces
  • Total impulse response manipulation
  • Pre-delay (positive or negative)
  • Two-band dedicated reverb EQ
  • Three-band routable EQ
  • Two sync-able delay lines
  • Tools for creating custom impulse responses
  • Reverb decay crossover network
  • Double precision processing
  • Low latency
  • Mono and stereo versions

System Requirements

Mac:

  • OSX 10.8 (or higher)

Windows:

  • Windows 7 (or higher)

Formats:

  • AAX Native
  • AU
  • VST

Platform Requirements:

  • AAX versions require Pro Tools 10.3.8 or higher, or Pro Tools 11.1.3 or higher
  • S6L versions require VENUE OS 5.2 or higher
  • AU versions recommended for Logic X, or higher
  • VST versions recommended for Cubase 7.x, 8.X, or higher, and Nuendo 6.5 or higher

More by McDSP

  • top rated
osxpc
6034 ultimate mb pluginboutique
5(1)
your price$179.00
    osxpc
    Ml8000 advanced limiter pluginboutique
    your price$129.00
      osxpc
      6020 ultimate eq pluginboutique
      your price$129.00
        osxpc
        Filterbank e606 pluginboutique
        your price$149.00