support reviews loopmasters.com
  • sale
  • top rated
macpc
32-bit / 64-bit

NF575 Noise Filter HD

Filter by McDSP

Buy and getFREE

Reason Lite Rack Plugin
Logo reasonstudios pluginboutique

Note: This product is the HD version. You can purchase the Native version HERE.

Accurate high pass and low pass filters reduce low frequency rumble and high frequency hiss. Selectable slopes of 6, 12, 18, 24, 30 and 36 dB/Oct and frequency control range covering the entire audible spectrum make the NF575 filters extremely flexible.

Advanced notch filters allow the user to select the amount of signal cut, cut frequency, and width (Q). All five NF575 notch filters can be linked harmonically to address common cyclical noise problems such as 60 Hz hum.

Features

  • High Pass Filtering (HPF) with slopes up to 36 dB/Oct
  • Low Pass Filtering (LPF) with slopes up to 36 dB/Oct
  • Five bands of notch filtering with linkable frequency control
  • Analog Saturation modeling
  • Double precision processing
  • Ultra low latency
  • Mono and stereo versions

System Requirements

Mac:

  • macOS 10.10 or higher (64-bit only)

Windows:

  • Windows 7, 8 & 10 (64-bit only)

HD v6 Software Supports:

  • AAX DSP and AAX Native
  • Audio Units (AU)
  • Audio Suite
  • VST

Platform Requirements:

  • AAX versions require Pro Tools 12.x or higher and also support Pro Tools 2018, 2019, and 2020.
  • S6L versions require VENUE OS 5.3.2 or higher
  • AU versions recommended for Logic X or higher
  • VST version recommended for Cubase 7.x, 8.x, 9.x, and 10.x, and Nuendo 6.5 or higher
  • McDSP plug-ins require a v6 license (or Demo) on an iLok2, iLok3, or iLok cloud to authorize the installers. Latest iLok drives are recommended. Cloud support requires v6.5 or higher

Compatible DAW's

McDSP HD and Native plug-ins are compatible with Pro Tools, Logic X, Cubase, Nuendo, Ableton Live, MOTU Digital Performer, Studio One, Sonar, and other DAWs that support AAX, AU, VST and/or VST3 plug-in formats.

Activation:

  •  Active internet connection required OR physical iLok USB Dongle required.

Important note: McDSP plug-ins require either a physical iLok2 or iLok3 USB Dongle or an iLok License Manager account and an iLok Cloud session for authorization.

Any references to any brands on this site/page, including reference to brands and instruments, are provided for description purposes only. For example references to instrument brands are provided to describe the sound of the instrument and/or the instrument used in the sample. Plugin Boutique do not have (nor do they claim) any association with or endorsement by these brands. Any goodwill attached to those brands rest with the brand owner. Plugin Boutique or its Suppliers do not accept any liability in relation to the content of the product or the accuracy of the description. "RHODES" is a registered trademark of Joseph A Brandstetter.

More by McDSP

  • sale
  • top rated
osxpc
Filterbank e606 pluginboutique
4(3)
your price$69.00
-53%
  • sale
  • top rated
osxpc
Sa2main pluginboutique
4(1)
your price$69.00
-61%
  • top rated
osxpc
Ec300 main pluginboutique
5(3)
your price$99.00
-44%
  • sale
osxpc
950x426 mcdsp retropack meta pluginboutique
starts from$49.00
learn more
  • sale
osxpc
4020 retro eq pluginboutique
starts from$29.00
learn more

You may also like

  • hot!
  • top rated
osxpc
Ea pheonixverb 3dbox
5(2999)
your price$99.00
  • hot!
  • top rated
osxpc
Voice leveler pluginboutique
4(3582)
your price$59.00
  • sale
  • top rated
osxpc
Analog channel both pluginboutique
4(1)
your price$69.00
-53%
  • sale
  • top rated
osxpc
Compressorbank 303 pluginboutique
4(14)
your price$49.00
-50%
  • sale
osxpc
Compressorbank 303 pluginboutique
your price$69.00
-53%
  • hot!
  • sale
  • top rated
osxpc
Mc2000 mb compressor pluginboutique
5(15)
your price$49.00
-50%